Delays in sending email

Incident Report for Loops

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 23:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2025 - 21:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 12, 2025 - 20:22 UTC

Update

We are continuing to investigate this issue.
Posted Mar 12, 2025 - 19:51 UTC

Investigating

Marketing email sending queues are delayed in processing their payloads.

We are currently investigating this issue.
Posted Mar 12, 2025 - 17:12 UTC
This incident affected: Email Sending (Loops, Campaigns, Transactional) and API.